Applicable Products and Versions
This example applies to all models and versions.
For details about the mapping between software versions and switch models, see the Hardware Query Tool.
Networking Requirements
On the data center network, manually setting system time on all devices is time-consuming and the system time may be inaccurate. The NTP protocol can quickly synchronize system time of all devices on the network.
As shown in Figure 2-37, the IP addresses of SwitchA and SwitchB have been configured. SwitchA has synchronized its clock to an authoritative clock, for example, the Global Positioning System (GPS). SwitchA functions as the time server of SwitchB.
Figure 2-37 Diagram for configuring NTP to synchronize time
Configuration Roadmap
The configuration roadmap is as follows:
- Configuring IP addresses for SwitchA and SwitchB
- Configuring SwitchA as the master clock so that the local clock of SwitchA can be used as the reference clock
- Configuring SwitchB to synchronize time from SwitchA and configuring NTP authentication to ensure time synchronization security
Procedure
- Configure IP addresses for SwitchA and SwitchB.
# Configure the IP address for SwitchA.
<HUAWEI> system-view [*HUAWEI] sysname SwitchA [~HUAWEI] commit [~SwitchA] vlan batch 100 [*SwitchA] interface vlanif 100 [*SwitchA-Vlanif100] ip address 10.10.1.1 24 [*SwitchA-Vlanif100] quit [*SwitchA] interface 10ge 1/0/1 [*SwitchA-10GE1/0/1] port link-type trunk [*SwitchA-10GE1/0/1] port trunk pvid vlan 100 [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 100 [*SwitchA-10GE1/0/1] quit [*SwitchA] commit
# Configure the IP address for SwitchB.
<HUAWEI> system-view [~HUAWEI] sysname SwitchB [~HUAWEI] commit [*SwitchB] vlan batch 100 [*SwitchB] interface vlanif 100 [*SwitchB-Vlanif100] ip address 10.10.1.2 24 [*SwitchB-Vlanif100] quit [*SwitchB] interface 10ge 1/0/1 [*SwitchB-10GE1/0/1] port link-type trunk [*SwitchB-10GE1/0/1] port trunk pvid vlan 100 [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 100 [*SwitchB-10GE1/0/1] quit [*SwitchB] commit
- Configure SwitchA as the master clock server and enable NTP authentication. Set the clock stratum to 1.
The value of clock stratum ranges from 1 to 15. The clocks on the subnet are synchronized in an ascending order of stratum. The clock stratum can be set. In this example, the clock stratum is 1.
In actual circumstances, the NTP server synchronized with the authoritative clock is set as stratum 1, and is used as a clock source. Other devices on the network synchronize their clocks with the clock of the NTP server, which means the local clock of the NTP server is configured as the NTP master clock.
[~SwitchA] ntp refclock-master 1 //Set the clock stratum to 1. [*SwitchA] ntp authentication enable [*SwitchA] ntp authentication-keyid 45 authentication-mode hmac-sha256 hello123456 //Authentication methods includes MD5 and HMAC-SHA256. HMAC-SHA256 has a higher security and MD5 has a higher speed. In this example, HMAC-SHA256 is used. [*SwitchA] ntp trusted authentication-keyid 45 [*SwitchA] commit
# Specify a listening interface on SwitchA.
[~SwitchA] ntp server source-interface vlanif 100 [*SwitchA] commit
- Enable the NTP server function of SwitchA.
[~SwitchA] undo ntp server disable [*SwitchA] commit [~SwitchA] quit
- Configure SwitchB to synchronize time with SwitchA and enable NTP authentication. The IP address of NTP server is 10.10.1.1.
[~SwitchB] ntp authentication enable [*SwitchB] ntp authentication-keyid 45 authentication-mode hmac-sha256 hello123456 //Authentication methods includes MD5 and HMAC-SHA256. HMAC-SHA256 has a higher security and MD5 has a higher speed. In this example, hmac-sha256 is used. [*SwitchB] ntp trusted authentication-keyid 45 [*SwitchB] ntp unicast-server 10.10.1.1 authentication-keyid 45 //Set the clock synchronization mode to unicast client/server. [*SwitchB] commit [~SwitchB] quit
The authentication key ID on SwitchB must be the same as that on SwitchA; otherwise, the authentication will fail.
Configuration File
Configuration file of SwitchA
#
sysname SwitchA
#
ntp ipv6 server disable
ntp authentication-keyid 45 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# //The ciphertext format provided here is for example only. The format may vary depending on the system software version.
ntp trusted authentication-keyid 45
ntp refclock-master 1
ntp authentication enable
ntp server source-interface Vlanif100
#
vlan batch 100
#
interface Vlanif100
ip address 10.10.1.1 255.255.255.0
#
interface 10GE1/0/1
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100
#
return
Configuration file of SwitchB
#
sysname SwitchB
#
ntp server disable
ntp ipv6 server disable
ntp authentication-keyid 45 authentication-mode hmac-sha256 cipher %^%#fhKx(LFg)~2:d23J_(t~RNcW9g#Bv7}a[7(%$HG-%^%# //The ciphertext format provided here is for example only. The format may vary depending on the system software version.
ntp trusted authentication-keyid 45
ntp unicast-server 10.10.1.1 authentication-keyid 45
ntp authentication enable
#
vlan batch 100
#
interface Vlanif100
ip address 10.10.1.2 255.255.255.0
#
interface 10GE1/0/1
port link-type trunk
port trunk pvid vlan 100
port trunk allow-pass vlan 100
#
return
Conclusions and Suggestions
The NTP usage scenarios are as follows:
- Unicast client/server mode: used at a higher stratum on a synchronization subnet. In this mode, the clients need to obtain the IP address of the server before synchronizing time.
- Peer mode: used at a lower stratum on the synchronization subnet. In this mode, an active peer and a passive peer can be synchronized with each other. To be specific, a peer of a higher stratum is synchronized to a peer of a lower stratum.
- Broadcast mode: used when the IP address of a server or peer is not determined, or when the clocks of a large number of devices need to be synchronized on a network.
- Multicast mode: used for the high-speed network that has multiple workstations and does not require high clock accuracy. In a typical scenario, one or more clock servers on the network periodically send multicast packets to the workstations. The delay of packet transmission in a LAN is at the milliseconds level.
- Manycast mode (V100R002C00 or later): used in the scenario where servers are scattered on a network. The client can discover and synchronize to the closest manycast server. On a network where the server is unstable, the manycast mode avoids reconfigurations on clients after the server changes.
The NTP traverses the following states during synchronization:
- clock not set: indicates that the clock is not updated.
- frequency set by configuration: indicates that the clock frequency is set by NTP.
- clock set: indicates that the clock is set.
- clock set but frequency not determined: indicates that the clock is set, but the clock frequency is not determined.
- clock synchronized: indicates that the clock has been synchronized.
- spike (clock will be set in XXX secs): indicates that the system detects that the time difference between the clock server and the client exceeds 128 milliseconds, and the local clock will be revalidated in XXX seconds.
If an error occurs in NTP synchronization, use the following methods to locate the fault:
- Run the display ntp event clock-unsync command to view the latest 10 reasons of NTP synchronization failures.
- Run the display ntp sessions command to view information about all sessions of local NTP.
- Run the display ntp slot-status command to view the clock system status.
Установка актуальной даты и времени является одной из первоочередных задач которую необходимо выполнить на сетевом оборудование, чтобы избежать дальнейшей путаницы при просмотре логов и т.п. Давайте разберем ручную устанавку timezone, даты и времени, а также настройку синхронизации времени с ntp-сервера на оборудование huawei.
1. Установка времени. Формат установки времени — HH:MM:SS
clock datetime 13:20:00
2. Установка даты. Формат установки даты — YYYY-MM-DD
clock datetime 13:20:00 2018-12-25
Просмотр текущей информации по установленом даты, времени и тайм зоны.
display clock 2017-06-02 14:22:06+03:00 Friday Time Zone(MSK) : UTC+03:00
Установка часового пояса на huawei
Установка Московского часового пояса +3 часа по Гринвичу (GMT).
clock timezone MSK add 03:00:00
Установка часового пояса -2 часа по Гринвичу (GMT).
clock timezone MSK minus 02:00:00
Cинхронизация времени с ntp сервером на huawei
Удобно выставлять время на железе не вручную, а синхронизировать его c ntp серверами. Для этого используем следующие команды.
ntp-service unicast-server IP-NTP-SERV-1 ntp-service unicast-server IP-NTP-SERV-2
Если у вас на сети используется MPLS и ntp сервер доступен через VRF, то в этом случае к настройкам добавляем параметр vpn-instanсe.
ntp-service unicast-server IP-NTP-SERV vpn-instance NAME-VRF
Просмотр общей информации ntp.
display ntp-service status clock status: synchronized clock stratum: 5 reference clock ID: XXX.XXX.XXX.XXX nominal frequency: 60.0002 Hz actual frequency: 60.0002 Hz clock precision: 2^17 clock offset: -2.3619 ms root delay: 337.70 ms root dispersion: 152.28 ms peer dispersion: 104.00 ms reference time: 11:14:45.392 UTC Jun 2 2017(DCDBC725.6472085B) synchronization state: clock synchronized
Просмотр информации о текущих сессиях установленных с ntp серверами.
display ntp-service sessions clock source: XXX.XXX.XXX.XXX clock stratum: 4 clock status: configured, selected, sane, valid reference clock ID: XXX.XXX.XXX.XXX reach: 377 current poll: 1024 now: 434 offset: 0.4184 ms delay: 57.38 ms disper: 16.15 ms clock source: XXX.XXX.XXX.XXX clock stratum: 4 clock status: configured, master, sane, valid reference clock ID: XXX.XXX.XXX.XXX reach: 377 current poll: 1024 now: 566 offset: -4.3471 ms delay: 63.11 ms disper: 16.75 ms
Шаблоны типовой настройки синхронизации времени с ntp сервером на huawei
Стандартный шаблон настройки для huawei.
clock timezone MSK add XX:XX:XX sys ntp-service unicast-server XXX.XXX.XXX.XXX ntp-service unicast-server XXX.XXX.XXX.XXX
Шаблон настройки для случая если ntp сервер доступен через VRF.
clock timezone MSK add XX:XX:XX sys ntp-service unicast-server XXX.XXX.XXX.XXX vpn-instance NAME-VRF ntp-service unicast-server XXX.XXX.XXX.XXX vpn-instance NAME-VRF
На этом все. Как видим ничего сложного в настройки даты и времени оборудование huawei нет. Комментируем, подписываемся ну и всем пока:)
Время на роутере Huawei WiFi AX3 играет важную роль, так как оно используется для синхронизации времени на всех устройствах, подключенных к сети. Правильное установление времени позволяет правильно отображать актуальную информацию и выполнять различные задачи, связанные с устройствами, синхронизированными по времени. В этой пошаговой инструкции мы расскажем вам, как настроить время на Huawei WiFi AX3.
Шаг 1: Подключитесь к вашему роутеру Huawei WiFi AX3 с помощью компьютера или мобильного устройства. Для этого используйте указанный в документации пароль доступа к сети.
Шаг 2: После подключения откройте веб-браузер и введите IP-адрес вашего роутера в адресной строке. Обычно это 192.168.3.1, но, при необходимости, вы можете узнать точный IP-адрес в документации к роутеру или обратившись к вашему интернет-провайдеру.
Шаг 3: В появившемся окне авторизации введите имя пользователя и пароль администратора вашего роутера. Если данные не были изменены, по умолчанию имя пользователя — admin, а пароль — admin.
Шаг 4: После успешной авторизации вам будет предложено меню настройки роутера. Найдите в нем раздел, связанный со временем или датой и временем. Обычно этот раздел называется «Time» или «Date & Time».
Шаг 5: В разделе настройки времени вы сможете изменить текущие значения времени и часового пояса. Введите правильные значения времени и выберите ваш часовой пояс из предложенного списка.
Шаг 6: После внесения изменений, нажмите кнопку «Сохранить» или «Применить» для применения новых настроек времени на вашем роутере Huawei WiFi AX3.
Теперь время на роутере будет правильным, что позволит вам синхронизировать время на всех устройствах в вашей сети и выполнять различные задачи, требующие синхронизации по времени.
Содержание
- Как настроить время на Huawei WiFi AX3
- Подробная инструкция по настройке времени на роутере Huawei WiFi AX3
- Шаг 1: Вход в настройки роутера
Как настроить время на Huawei WiFi AX3
Для настройки времени на роутере Huawei WiFi AX3 следуйте этим шагам:
- Войдите в интерфейс управления роутером, введя его IP-адрес в адресной строке браузера.
- Введите имя пользователя и пароль для доступа к настройкам роутера.
- В меню настроек найдите раздел «Настройки времени» или «Системное время».
- Выберите свой часовой пояс из выпадающего списка или введите его вручную.
- Установите нужное время и дату в соответствии с текущими настройками.
- Сохраните изменения и перезагрузите роутер, чтобы изменения вступили в силу.
После выполнения этих шагов время на Huawei WiFi AX3 будет настроено и отображаться правильно на устройствах, подключенных к роутеру.
Подробная инструкция по настройке времени на роутере Huawei WiFi AX3
Шаг 1: Подключите устройство к роутеру Huawei WiFi AX3 с помощью провода Ethernet или через беспроводное соединение Wi-Fi.
Шаг 2: Откройте веб-браузер и введите IP-адрес роутера Huawei WiFi AX3 в адресной строке. Обычно IP-адрес роутера указан на наклейке на задней панели устройства. Нажмите enter, чтобы перейти к настройкам роутера.
Шаг 3: Введите ваши учетные данные для входа в систему, включая имя пользователя и пароль. Если вы не меняли эти данные, по умолчанию имя пользователя «admin», а пароль «admin» или «password».
Шаг 4: После успешной авторизации откроется панель управления роутером. Найдите вкладку «Настройки времени» или «Time Settings».
Шаг 5: Во вкладке настройки времени найдите поле «Часовой пояс» или «Time Zone». Выберите вашу текущую временную зону.
Шаг 6: Введите текущую дату и время в соответствующие поля. Вы также можете включить опцию автоматической синхронизации времени с сервером ниже.
Шаг 7: Нажмите на кнопку «Сохранить» или «Применить», чтобы сохранить настройки времени.
Шаг 8: После сохранения настроек роутер перезагрузится, и новые настройки времени вступят в силу.
Шаг 9: Проверьте корректность настроек времени, открыв веб-браузер на подключенном устройстве и загрузив какую-либо страницу.
Следуя этой подробной инструкции, вы сможете настроить время на вашем роутере Huawei WiFi AX3 максимально корректно, что обеспечит бесперебойную работу роутера и основных функций устройства.
Шаг 1: Вход в настройки роутера
Первым шагом для настройки времени на Huawei WiFi AX3 необходимо войти в настройки роутера. Для этого выполните следующие действия:
Шаг 1.1: Подключитесь к Wi-Fi сети, созданной вашим роутером Huawei WiFi AX3. Имя и пароль по умолчанию указаны на задней панели роутера.
Шаг 1.2: Откройте веб-браузер на устройстве, подключенном к роутеру. В адресной строке введите IP-адрес роутера (по умолчанию это 192.168.3.1) и нажмите клавишу Enter.
Шаг 1.3: В появившемся окне введите имя пользователя и пароль для входа в настройки роутера (по умолчанию имя пользователя: admin, пароль: admin). Нажмите кнопку «Войти».
Шаг 1.4: После успешного входа вы попадете в главное меню настроек роутера Huawei WiFi AX3 и будете готовы приступить к настройке времени.
Часто требуется настройка времени на сетевом оборудовании. Например, чтобы настроить время на оборудовании Huawei (6810, 5700 и т.д.) надо:
Перейти в перивелегированый режим
sys
Если вручную надо установить, то
clock datetime hh:mm:ss YYYY-MM-DD
Добавляем временную зону
clock timezone MSK add hh:mm:ss
или
clock timezone MSK minus hh:mm:ss
Если забирать в простом варианте с NTP-сервера, то
ntp-service unicast-server XXX.XXX.XXX.XXX
Категории: Huawei
Метки: huawei, сети
One of the Best Security Practice and Recommendation is to configure Huawei Router in client mode and never run as NTP server.
NTP Server1: 192.168.10.101
NTP Server1: 192.168.10.102
Configuration:
ntp-service server disable
ntp-service ipv6 server disable
ntp-service unicast-server 192.168.10.101
ntp-service unicast-server 192.168.10.102
Verification:
display ntp-service status
display ntp-service sessions
If authentication is enabled on your NTP server.
-Enable the NTP service authentication function
-Configure the NTP authentication key
-Specify the NTP key
-Configure the NTP server(s) with the authentication key id
ntp-service authentication enable
ntp-service authentication-keyid <key-id> authentication-mode { md5 | hmac-sha256 } { cipher } <password>
ntp-service reliable authentication-keyid <keyid>
ntp-service unicast-server 192.168.10.101 authentication-keyid <key-id>
ntp-service unicast-server 192.168.10.102 authentication-keyid <key-id>